Multithread Support Windows Broken

Discuss emulation or program issues here.
Post Reply
User avatar
Breadwinka
Posts: 54
Joined: Fri Oct 04, 2013 11:35 pm

Multithread Support Windows Broken

Post by Breadwinka » Tue Jan 26, 2016 8:13 pm

Im sure you already know this broken on windows builds at least. The MT build you shared on Reddit works but the latest download with the -mulithread argument doesnt. Just a white screen with like 500VI/s

User avatar
MarathonMan
Site Admin
Posts: 692
Joined: Fri Oct 04, 2013 4:49 pm

Re: Multithread Support Windows Broken

Post by MarathonMan » Tue Jan 26, 2016 11:00 pm

Heh, thanks for the report... krom mentioned the same thing last night when I was knees deep in audio fixes.

The multithreading code is largely the same so I'm not sure what broke. I will fix it soon.

User avatar
MarathonMan
Site Admin
Posts: 692
Joined: Fri Oct 04, 2013 4:49 pm

Re: Multithread Support Windows Broken

Post by MarathonMan » Wed Jan 27, 2016 1:31 am

Fixed and builds updated.

User avatar
Nintendo Maniac 64
Posts: 185
Joined: Fri Oct 04, 2013 11:37 pm

Re: Multithread Support Windows Broken

Post by Nintendo Maniac 64 » Wed Jan 27, 2016 7:19 pm

Multithreaded runs fine now but it seems like it doesn't terminate the process when you close the Cen64 window.

(single threaded by comparison does terminate the process when closing the Cen64 window, but it also almost always gives a "has stopped working" error when closing)
CEN64 Forum's resident straight-male kuutsundere
(just "tsundere" makes people think of "Shana clones" *shivers*)

CPU+iGPU: Pentium G3258 @ 4.6GHz/1.281v
dGPU: Radeon HD5870 1GB
RAM: Vengeance 1600 4x4GB
OS: Windows 7

User avatar
MarathonMan
Site Admin
Posts: 692
Joined: Fri Oct 04, 2013 4:49 pm

Re: Multithread Support Windows Broken

Post by MarathonMan » Thu Jan 28, 2016 12:23 am

Also happens on other platforms and a known issue as well. Thanks though.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest