AVX builds on Windows

Discuss emulation or program issues here.
Post Reply
User avatar
MarathonMan
Site Admin
Posts: 692
Joined: Fri Oct 04, 2013 4:49 pm

AVX builds on Windows

Post by MarathonMan » Mon Jan 12, 2015 11:45 am

Breadwinka wrote:AVX version crashes to on windows. Definitely a windows build problem.
Can anyone else report similar problems?

User avatar
e2118289
Posts: 13
Joined: Tue Dec 31, 2013 12:24 am

Re: AVX builds on Windows

Post by e2118289 » Mon Jan 12, 2015 1:02 pm

MarathonMan, it's not just AVX builds...
Nintendo Maniac 64 wrote:Ok, something is very wrong - my MD5 hashes match up to Nacho's but on booting both games I just get a grey image and the emulation locks up.

FYI I'm using the Win64 sse 4.1 version built at 2015-01-10 21:21 as according to here:
http://downloads.cen64.com/

EDIT: :arrow: Same issue occurs with the SSE2 and SSSE3 builds, but I can't test the AVX build due to not having any AVX-capable CPUs.
Shortly after that:
Breadwinka wrote:AVX version crashes too on windows. Definitely a windows build problem.
It must be a core issue! Tested all the way down to revision ca8e052 [Add (unoptimized) SSE2 support.] and Pokemon Stadium 2 (U) [!].z64 crashes shortly after booting every time! It's a pity I can't help any further :(

User avatar
siggie
Posts: 5
Joined: Mon Nov 04, 2013 2:23 pm

Re: AVX builds on Windows

Post by siggie » Mon Jan 12, 2015 2:22 pm

Pokemon Stadium 2 crashes instantly. Just like "Legend of Zelda, The - Majora's Mask (USA).z64"
No problems running the following:
Super Mario 64 (U) [!].z64
Legend of Zelda, The - Ocarina of Time (USA).z64

This all with a 3770K cpu

User avatar
chriztr
Posts: 38
Joined: Sun Oct 06, 2013 4:15 pm

Re: AVX builds on Windows

Post by chriztr » Mon Jan 12, 2015 5:24 pm

instant crash:
zelda mm
zelda mm demo disk
tony hawk's pro skater 3

hangs / loops with white screen
donkey kong 64

latest avx build 21:21, win 8 x64

User avatar
MarathonMan
Site Admin
Posts: 692
Joined: Fri Oct 04, 2013 4:49 pm

Re: AVX builds on Windows

Post by MarathonMan » Tue Jan 13, 2015 10:16 am

e2118289 wrote:Tested all the way down to revision ca8e052 [Add (unoptimized) SSE2 support.] and Pokemon Stadium 2 (U) [!].z64 crashes shortly after booting every time! It's a pity I can't help any further :(
Are you saying that's the exact commit where it stopped working, or just where you last tested?

User avatar
MarathonMan
Site Admin
Posts: 692
Joined: Fri Oct 04, 2013 4:49 pm

Re: AVX builds on Windows

Post by MarathonMan » Tue Jan 13, 2015 6:23 pm

Bump. I think these are unrelated/known issues.

e2118289 - your graphics card isn't capable of running CEN64 ATM. See: http://forums.cen64.com/viewtopic.php?f=10&t=158#p1687
chriztr wrote:hangs / loops with white screen
donkey kong 64
Fixed.
chriztr wrote:instant crash:
zelda mm
zelda mm demo disk
tony hawk's pro skater 3
siggie wrote:Pokemon Stadium 2 crashes instantly. Just like "Legend of Zelda, The - Majora's Mask (USA).z64"
Try now.

User avatar
chriztr
Posts: 38
Joined: Sun Oct 06, 2013 4:15 pm

Re: AVX builds on Windows

Post by chriztr » Wed Jan 14, 2015 2:42 pm

No change with latest build (2015-01-13 23:00)

User avatar
siggie
Posts: 5
Joined: Mon Nov 04, 2013 2:23 pm

Re: AVX builds on Windows

Post by siggie » Wed Jan 14, 2015 2:59 pm

Boots:
Donkey Kong 64 (USA).z64
Instant crash:
Legend of Zelda, The - Majora's Mask (USA).z64
Pokemon Stadium 2 (USA).z64

Tony Hawk's Pro Skater 3 (USA).z64 crashed with the following error msg:
This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.

User avatar
e2118289
Posts: 13
Joined: Tue Dec 31, 2013 12:24 am

Re: AVX builds on Windows

Post by e2118289 » Fri Jan 16, 2015 3:01 am

MarathonMan wrote:Are you saying that's the exact commit where it stopped working, or just where you last tested?
My CPU supports up to SSE3 instructions so I couldn't test further.
MarathonMan wrote:e2118289 - your graphics card isn't capable of running CEN64 ATM. See: http://forums.cen64.com/viewtopic.php?f=10&t=158#p1687
Nooo really? :roll: :lol:
Simulation still works, except I can't see what happens! CEN64 doesn't crash!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest